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1 General 

 

1.1 Information on the Operating Instructions 

Read the operating instructions carefully before starting any work! 

They are part of the product and must be kept in the immediate  

vicinity of the product where they are accessible to personnel at all 

times. 

If the product is transferred to a third party, also provide the operat-

ing instructions. 

This user manual provides important information on how to use the 

product. The manual describes the AHD-WNL logging system and its 

accompanying data analysis software. 

Compliance with all specified safety instructions and operating in-

structions for the product and all components connected to it is a 

prerequisite for safe operation. 

In addition, all local accident prevention regulations and general safe-

ty regulations applicable to the product’s intended use must be ob-

served. 

The illustrations in this manual are not necessarily to scale and may 

differ slightly from the actual design of the product. 

These operating instructions are to be understood exclusively as a 

single unit. The use of excerpts from these operating instructions as 

standalone documentation without reference to the complete docu-

ment is not permitted. 

 

 

 

1.2 Explanation of Symbols 

   

Warnings Warnings in this operating manual are indicated by symbols. The 

warnings are introduced by signal words that indicate the severity of 

the hazard.  

 

Always follow the instructions and act with caution to prevent acci-

dents, personal injury, and property damage! 

       

 

DANGER! 

… indicates an immediately dangerous situation that 

can lead to death or serious injury if not avoided. 

 

 

WARNING! 

… indicates a potentially dangerous situation that 

can lead to death or serious injury if not avoided. 
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CAUTION! 

… indicates a potentially dangerous situation that 

could result in minor or slight injuries if not 

avoided. 

 

 

 

CAUTION! 

… indicates a potentially dangerous situation that 

could result in property damage if not avoided. 

  

 

Tips and Recommendations 

 

 

 

NOTE! 

… highlights useful tips and recommendations as 

well as information for efficient and trouble-free op-

eration. 
    

 

 

1.3  Limitation of Liability 

All information and instructions in this manual have been compiled in 

accordance with applicable standards and regulations, the state of 

the art, and our many years of knowledge and experience. 

The manufacturer assumes no liability for damages resulting from: 

⚫ Failure to follow the manual 

⚫ Improper use 

⚫ Use by untrained personnel 

⚫ Unauthorized modifications 

⚫ Technical modifications 

⚫ Use of non-approved replacement parts 

The actual scope of delivery may differ from the descriptions and il-

lustrations provided here in the case of special versions, the use of 

additional ordering options, or due to the latest technical modifica-

tions. 

In all other respects, the obligations agreed upon in the delivery con-

tract, the General Terms and Conditions, the manufacturer’s delivery 

terms, and the legal regulations in effect at the time the contract is 

concluded shall apply. 

  

We reserve the right to make technical changes for the purpose of 

improving performance characteristics and further development.  
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1.4 Copyright 

The operating instructions must be treated as confidential. They are 

intended exclusively for persons working with the product. The trans-

fer of the operating instructions to third parties without the manu-

facturer’s written permission is prohibited. 

 

 

NOTICE! 

The content, texts, drawings, images, and other rep-

resentations are protected by copyright and subject 

to industrial property rights. Any unauthorized use is 

punishable by law. 
 

Reproduction in any form or manner - including in part - as well as 

the use and/or disclosure of the content is prohibited without the 

manufacturer’s written consent. Violations will result in liability for 

damages. We reserve the right to assert further claims. 

 

 
  

 
 

1.5 Warranty Terms 

 

The warranty terms can be found in the sales documents and the 

manufacturer’s General Terms and Conditions (GTC). 

 

 
 

1.6 Customer Service 

Our customer service is available for technical inquiries. 

Information regarding the responsible contact person is available at 

any time by phone, fax, email, or via the Internet; see the manufac-

turer’s address on page 2. 

In addition, our employees are always interested in new information 

and experiences arising from product use that may be valuable for 

improving our products. 
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2 AHD-WNL Protocol PC 

2.1 General 

The AHD-WNL is a black-box PC with a closed operating system that 

has been specifically designed as a protocol computer with logging 

functionality. The system enables the storage of system-relevant  

logging data and logs measurement values and events captured via 

the ship’s network of the connected alarm and monitoring system. 

All collected data can be displayed on the ship system’s panel PCs or 

displays or exported in various formats.  

 

Figure 1: AHD-WNL (Black-Box PC System) 

 

AHD-WNL was developed specifically for the shipbuilding industry. 

The passive cooling system and the use of a solid-state drive allow for 

a design without moving parts that offers very high shock resistance. 

The integrated battery pack ensures the controlled shutdown of the 

PC even in the event of a sudden power failure. Alternatively, the 

shutdown can also be controlled via an external digital input (e.g., 

ignition detection in engine systems).  

 

2.2 Connection to the Böning ship network 

AHD-WNL is directly connected via LAN-1 to an AHD-DPU 9 data sta-

tion within the Böning ship network. The existing system configura-

tion is adjusted so that all relevant measurement channels are trans-

mitted to the AHD-WNL. The assigned measurement points and 

events are processed and permanently stored on a solid-state drive 

(SSD). The AHD-WNL has a storage capacity for approximately 50  

million measurement values and 100,000 events. 
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2.3 Data Recording 

The measurement channels received by AHD-WNL are recorded either 

event-driven or cyclically, depending on their configuration. Depend-

ing on the data type, the following storage cycles can be selected: 

▪ Binary data: 

on status changes or max. every 2 seconds 

▪ Rapidly changing analog data: 

on status changes or max. every 2 seconds 

▪ Slow-changing analog data: 

on status changes or every 10 seconds to 1 hour 

(Applications such as tank levels, temperatures, or operating 

hours) 

The maximum possible recording duration depends on the selected 

storage cycles and is determined on a customer-specific basis. All 

stored data can be displayed on the ship system’s panel PCs or dis-

plays or exported in various formats.  

 

2.4 Data output 

Data output is typically handled within the graphical system configu-

ration by embedding so-called “logging pages”. These are created 

within the project-specific visualization and enable the implementa-

tion of predefined query functions tailored to customer requirements. 

Frequently recurring queries for key data points or sensors can thus 

be executed easily and conveniently (see example views at Figure 2 

and Figure 3). 

 

 

Figure 2: Data Logging / Trending page including preset buttons for predefined measurement channels 
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Figure 3: Data logging / trending page with multiple graphs (up to 8 measurement channels possible) 

  

As an alternative to the embedded logging pages, the data analysis 

software described below can also be used: 

  

3 Data Analysis Software 

Böning has developed two different software tools for data display, 

evaluation, and data backup via an export function. These are  

installed on any PC or laptop and connected to the AHD-WNL’s  

customer network (LAN-2). 

 

▪ AHD-Charting Tool: 

With “AHD-Charting” (see pos. 3.1), the values logged in the 

AHD-WNL can be read out, displayed graphically, and exported 

as a Microsoft Excel file (xls). Frequently used settings can be 

saved as profiles within AHD-Charting. 

 

▪ WNL Exporter Tool: 

With "WNL Exporter" (see pos. 3.2), the data to be logged is 

exported directly to an Excel file. Fixed timestamps can be de-

fined, which allows for better value comparison based on a 

common time reference. Furthermore, data export can be  

automated on a cyclical basis using a batch file or a task 

scheduler. 
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3.1 AHD-Charting Tool 

Within the AHD-WNL configuration, you specify which channels of 

the connected ship network are to be logged. With “AHD-Charting,” 

the logged values can be read out using a computer or laptop, dis-

played graphically, and exported as a Microsoft Excel file (xls). The 

querying PC is connected to the customer network (LAN-2) for this 

purpose.     

 

     

3.1.1 Requirements for Software- Installation 

The following requirements must be met to use AHD-Charting: 

• AHD-WNL installed and running, which logs data channels 

according to the configuration 

• Computer (PC or laptop) running Microsoft Windows 
XP®  

or later 

• Ethernet cable 

• The IP address of one of the AHD-WNL’s LAN interfaces must 

be known 

• Microsoft .NET Framework 4 Client Profile (x86 or x64) 

• 20 MB of free space on the hard drive or another storage 

medium where the program will be copied for installation. 

• The computer running AHD-Charting and the AHD-WNL LAN 

interface being used must be on the same network. Upon 

delivery, AHD-WNL uses the following configurable settings 

for LAN1: 

– IP address 192.168.11.200 

– Subnet mask 255.255.255.0 

– Default gateway 

 

The IP address 192.168.1.200 is used for LAN-2. 

Accordingly, the computer’s LAN interface must have an IP 

address in the form 192.168.11.XXX for connection to LAN1 

or 192.168.1.XXX for connection to LAN2. For XXX, enter a 

value between 1 and 255 that is not already in use on the re-

spective network. Use 255.255.255.0 as the subnet mask. 

Configuring the LAN interface requires administrator rights. 

The procedure depends on the operating system used and is 

described in the AHD-WNL operating instructions. 
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3.1.2 AHD-Charting Installation  

AHD-Charting is available on the manufacturer’s website. 

To install AHD-Charting, copy the downloaded files to a folder where 

you have write permissions. 

The AHD-Charting installation folder contains the executable file 

AHD-Charting.exe, which is used to launch AHD-Charting. 

 

Figure 4: AHD-Charting.exe 

 

 

NOTE! 

To make it easier to launch AHD-Charting, you can  

create a shortcut to the AHD-Charting.exe file, for  

example, on the desktop. 
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3.1.3 AHD-Charting Operation 

 

3.1.3.1 Starting 

To start AHD-Charting, double-click the AHD-Charting.exe file in the 

AHD-Charting installation folder or, if available, a shortcut to this file. 

The AHD-Charting startup screen appears: 

 

Figure 5: Start Screen 

 

The AHD-Charting startup screen contains the following elements: 

1. The "File" menu for working with profiles and exiting AHD-

Charting 

2. The "Export" menu for exporting data 

3. The "Help" menu for accessing information about AHD-

Charting and the help 

4. The "WNL" combo box for selecting the IP address of the 

AHD-WNL 

5. The "Connect" button for connecting to the selected AHD-

WNL. 

Once the connection is established, the button is labeled 

"Disconnect." 

6. The "Channel" list box for selecting channels 

7. The "Add" button for adding a channel to the chart area 

8. The "Remove All" button to remove channels from the graph 

area 

9. The “Export All” button for exporting data 

10. The "Refresh" button to update the values 

11. The empty chart area 
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3.1.3.2 Version information and help 

The version number of AHD-Charting is displayed in its title bar. 

To view more information about AHD-Charting, open the "Help" 

menu and select "About." 

 

Figure 6: Information about AHD-Charting 

To open this manual as a Windows help file, press the F1 key, select 

the "Help" entry in the "Help" menu, or click "Help" in the window con-

taining information about AHD-Charting. 

When channels are loaded, a brief help message on using the mouse 

appears in the chart area. 

 

Figure 7: Help on using the mouse 

 

3.1.3.3 Connecting to AHD-WNL 

AHD Charting reads the logged data from the AHD-WNL via its  

LAN-2 interfaces (Default setting). If necessary, an Ethernet switch 

can also be used. 

In the "WNL" field, enter the IP address of the AHD-WNL LAN inter-

face being used. Previously entered IP addresses can be selected from 

a list by clicking the arrow to the right of the field. 

To establish the connection, click the "Connect" button (5). 
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If the connection cannot be established, the following message is 

displayed: 

 

Figure 8: Connection to AHD-WNL not established 

 

In this case, check the entered IP address and the connection to AHD-

WNL. 

Once the connection to AHD-WNL is established, the AHD-Charting 

interface will display additional elements. 

 

 

Figure 9: Interface after connecting to AHD-WNL 

 

12. The chart area with the "Time/UTC" time axis and the "Value" 

value axis 

13. The “Show Points” checkbox 

14. The name of the loaded profile 

15. The connection status with AHD-WNL 
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3.1.3.4 Display channels 

After the connection to AHD-WNL has been established, the channels 

configured for logging are displayed in the “Channel” list box (6). 

 

Figure 10: List of channels 

 

To display a channel in the graph area, select it in the "Channel" list 

box (6) and click "Add" (7). The channel is displayed in the graph  

area (12). 

 

Figure 11: Interface with loaded channels 

 

A list of the loaded channels is displayed on the right side of the 

graph area. 

16. The color used to display the channel, the channel name, 

and, if applicable, the unit of the measured value 

17. Buttons for scaling the curve 

18. Buttons for removing the channel from the graph 
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3.1.3.5 Show points 

By default, the logged values are displayed as curves. To additionally 

display the individual values as points, enable “Show points” (13). 

 

3.1.3.6 Hide Channels 

Loaded channels can be hidden in the chart area. 

To hide a channel, click on the channel name in the list of loaded 

channels (16). The names of hidden channels are displayed in gray. 

 

Figure 12: Channel list with hidden channels 

 

3.1.3.7 Removing Channels 

To remove a channel from the graph, click the cross icon  in the list 

of loaded channels. 

You can also remove a channel by clicking “Remove All” (8), opening 

the “Remove one” menu, and selecting the desired channel. 

 

Figure 13: Removing individual channels with Remove All 

To remove all channels, click “Remove All” (8). 

 

3.1.3.8 Zoom the timeline 

To zoom in on a section of the timeline with the displayed curves, 

drag the left mouse button to draw a frame around the desired area 

of the curve. The inside of the frame will be highlighted in blue. 
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Figure 14: Selecting a time range to zoom 

 

After releasing the mouse button, the blue-highlighted portion of the 

curve is displayed in a larger view. 

 

Figure 15: Zoomed-in timeline 
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To display all values again, double-click in the  

chart area. 

 

3.1.3.9 Zooming the value axis 

To zoom the value axis, scroll the mouse wheel. 

Scrolling the mouse wheel up enlarges the time axis; scrolling down 

reduces it. 

The time axis is adjusted automatically. 

To display all values again, double-click in the chart area. 

3.1.3.10 Scale channel values 

To make the chart clearer, the values can be scaled using specified 

factors. 

To scale the values of a loaded channel, click the button for selecting 

scaling factors in the list of loaded channels  (17). 

 

Figure 16: Scaling factors for channels 

The channel’s values are divided by the selected factor. 

 

3.1.3.11 Moving in the chart 

To move the displayed curve in the graph, right-click and drag the 

mouse while holding down the mouse button. 

To display the original view, double-click with the left mouse button 

in the chart area. 

 

3.1.3.12 Display individual values 

To display individual values for a channel, press the CTRL key and 

simultaneously drag the crosshairs displayed by the mouse pointer to 

the desired point on the curve. 
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Figure 17: Displaying individual values 

 

The crosshairs display the date and time of the value as the X-value 

and the channel value as the Y-value. 

 

3.1.4 Exporting data 

The data for all loaded channels or individual channels can be export-

ed in xls format to Microsoft Excel
®
. 

To export only a section of the data, zoom in on the desired area. 

 

3.1.4.1 Data from a single channel 

To export data from a single channel, click “Export All” (9), open the 

“Export one” menu, and select the desired channel. 

 

Figure 18: Selecting individual channels for export 
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The same function is also available in the "Export" menu. Click on "Ex-

port," open the "Export one channel" menu, and select the channel. 

 

Figure 19: Exporting individual channels using the "Export" menu 

 

In the window that opens, specify the save location and file name. 

 

3.1.4.2 Data for all channels 

To export data from all loaded channels, click “Export All” (9) or se-

lect “Export all selected” from the “Export” menu. Channels hidden in 

the graph are also exported. 

In the window that opens, specify the save location and file name. 

The exported data is saved in Microsoft 
Excel®

 XLS format. 

 

3.1.4.3 The data in Microsoft Excel 

A separate worksheet is created in the Excel file for each channel. 

 

Figure 20: Exported data in Excel 
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Each worksheet contains the following columns: 

• Date: Date 

• Time: Time 

• Value: Channel value 

• Alarm: Type of triggered alarm 

• Valid: Validity status 

 

3.1.5 Profiles 

To quickly load frequently used channels from an AHD-WNL into 

AHD-Charting, you can create profiles. 

The following data is stored in profiles: 

• The IP address of AHD-WNL 

• The first date displayed 

• The last date displayed 

• The channels and the set scaling factors 

Currently, when loading a saved profile, the IP address of AHD-WNL, 

the channels, and their scaling factors are taken into account. 

 

3.1.5.1 Create Profiles 

Load the desired channels of an AHD-WNL into AHD-Charting and, if 

necessary, configure additional settings that can be saved in the pro-

file. 

Press the keyboard shortcut CTRL+S or open the "File" menu and se-

lect "Save profile…". 

 

Figure 21: Profile entries in the "File" menu 

 

In the window that opens, specify a save location and file name for 

the profile. 

To save a loaded profile under a different name, select "Save profile 

as..." from the "File" menu and specify the save location and file 

name. 
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3.1.5.2 Loading Profiles 

To load a saved profile, press the keyboard shortcut CTRL+O or open 

the "File" menu and select the "Open profile" option. 

Select the desired profile in the window that opens. 

To load one of the most recently used profiles, open the "File" menu, 

select "Recent profiles," and choose one of the displayed profiles. 

 

Figure 22: Selecting recently used profiles 

 

Channels that have already been loaded continue to be displayed 

with their current scales. The name of the most recently loaded pro-

file is shown in the lower-left corner of AHD-Charting (14). 

 

3.1.6 Disconnect from AHD-WNL 

To disconnect from the AHD-WNL selected in “WNL” (1), click “Dis-

connect” (2). 

You can now select a different AHD-WNL in “WNL” (1) and connect 

AHD-Charting to it. 

3.1.7 Exit AHD-Charting 

To close AHD-Charting, click the cross  in the upper-right corner of 

its window, or open the “File” menu and select “Exit.” 
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3.2 AHD Exporter Tool 

With the “WNL Exporter” client tool, the values logged in the AHD-

WNL can be exported directly to an Excel file. 

To ensure a common time base, timestamps can be defined within a 

specified range. This allows for better value comparison during sub-

sequent analysis. Furthermore, data export can be automated on a 

cyclical basis using a batch file or a task scheduler. Frequently used 

settings can be saved as profiles and loaded into AHD-Charting. 

 

3.2.1 Command-Line Query 

Data retrieval using the “WNL Exporter” client tool is performed via 

command lines using predefined parameters, as follows:  

Parameter 

Short Long  Example Description  

-o --output  -o export.xlsx Required: Output XLSX filename (the .xlsx exten-

sion is automatically added if not specified) 

-w --wnl  -w 192.168.11.200 Required: IP address/hostname of the WNL to 

connect to 

-c --channels  -c 1.2.3 1.2.4 

  

Required: Space-separated list of channels to 

export 

-s --start  -s "2020-10-23 22:33:00" (Default: today 00:00:00) Start date and time in 

UTC: "yyyy-MM-dd HH:mm:ss"  

-e --end  -e "2020-10-24 22:33:00" (Default: now) End date and time in UTC: "yyyy-

MM-dd HH:mm:ss"  

-i --interval  -i 30 (Default: 10) Interval between values in seconds 

-n --no-status  Remove the status column (GOOD/BAD)  

 

--help  Display help 

 

--version  Display version information 

 

Please note 

▪ The date and time must be entered exactly in the format "yyyy-

MM-dd HH:mm:ss", as follows: 

- yyyy: Year: 4 digits (e.g., 2020) 

- MM: Month: 2 digits (e.g., 03) 

- dd: Day: 2 digits (e.g., 18) 

- Space to separate the date and time 

- HH: Hours: 2-digit 24-hour format with a leading 0 (e.g., 22 or 08) 

- mm: Minutes: 2 digits (e.g., 44) 

- ss: Seconds: 2 digits (e.g., 00) 

- Don’t forget the quotation marks (""")   
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▪ Whenever possible, an output file is always created; an existing 

file with the same name will be overwritten without notice! The 

.xlsx extension is added if no file name extension was specified. 

▪ The channels specified in the list must be separated by spaces. 

▪ The specified interval must be an integer and greater than 0. 

▪ The command line length may be limited depending on the 

Windows version. 

▪ If the maximum number of rows allowed by Excel (.xlsx export 

file) is exceeded, an error message will be displayed. In this case, 

the interval must be increased or a shorter time period selected. 

 

Query examples 

Command line Action 

wnlexporter-cli.exe -w 

192.168.11.200 -c 1.2.3 1.2.4 -o 

export.xlsx 

Export channels 1.2.3 and 1.2.4 from WNL, IP address 

192.168.11.200, from 00:00 today until now to the file 

export.xlsx 

wnlexporter-cli.exe -w 

192.168.11.200 -c 1.2.3 1.2.4 -n -i30 

-o export.xlsx 

Export channels 1.2.3 and 1.2.4 from WNL, IP address 

192.168.11.200, from 12:00 AM today until now to the file 

export.xlsx  

wnlexporter-cli.exe -w 

192.168.11.200 -c 1.2.3 1.2.4 -o 

export.xlsx -s "2020-10-23 22:33:00" 

Export without status column, interval = 30s 

wnlexporter-cli.exe -w 

192.168.11.200 -c 1.2.3 1.2.4 -o 

export.xlsx -s "2020-10-23 22:33:00" -

e "2020-10-24 22:33:00" 

Export channels 1.2.3 and 1.2.4 from WNL, IP address 

192.168.11.200, from 2020-10-23 22:33:00 to the pre-

sent, to the file export.xlsx 

 

Return Values 

The following return values can be evaluated by the calling tool as 

needed.  

 

Code Description Comment 

0 Success Query successful 

1 Invalid parameters Check parameter list 

2 Cannot connect to WNL Check connection to WNL 

3 Cannot write to file Check path and file status  

100 Unknown error e.g., maximum number of Excel rows 

exceeded (see notes)  
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